CentOS 5.5 安裝 Apache 2.2.x (教學筆記)


Cent 5.5 安裝 Apache 2.2.x,首先移除現有的版本

下載 Apache 2.2.x (這裡用2.2.17做測試)
http://httpd.apache.org/download.cgi#apache22

安裝步驟如下:
1. 解壓縮 httpd-2.2.17.tar.gz

2. 執行 .configure 進行設定

第一次進行設定得時候發生錯誤,因此無法產生 makefile,錯誤訊息如下:

"configure: error: ...No recognized SSL/TLS toolkit detected"

因為我們在設定中選擇使用 "--enable-ssl" 但是找不到可用的 header 進行編譯,可透過安裝 SSL 套件來解決問題。

重新執行上一個步驟 .configure 產生 makefile

3. 進行編譯與安裝

完成!!

Facebook 留言

廣告

樂樂童鞋